Stuck on OS 3.1.2 and the apps want 3.1.3 already? There’s a hack for that!

With OS 4.0 just around the corner and a jailbreak for OS 3.1.3 only recently released, quite a few people are still using the good old OS 3.1.2, which has been the only choice for all the free-minded jailbreakers for almost 6 months. But more and more, apps and games on the AppStore require the 3.1.3 OS as a minimum, effectively locking out users of the older OS for now.

Well, it seems there’s a hack for that!

With the minor differences in the versions 3.1.2 and 3.1.3 there is no reason why anything should have the latter as a minimum requirement. Taking this into account, a French developer released a small hack in Cydia that makes iTunes and all of the apps installed think you’re actually on the latest firmware. This does NOT do the actual upgrade, so if an app actually tries to use an API present in 3.1.3 only, it will crash.

If you’re (like me) in need of running apps with OS 3.1.3 as a minimum, or simply want iTunes to stop bugging you about the upgrade, here are the details:

  • Repository: SOS iPhone (install it if you haven’t already from the repository packages in Cydia)
    • Go to Manage –> Sources and add http://cy.sosiphone.com/
  • Search for the Fake 3.1.3 package and install it.

Remember to Reboot after installation.

Next ArticleOfficial Twitter app now live on App Store